Forums
Ventana Wilderness Forums • View topic - How to embed a youtube video in your post.

How to embed a youtube video in your post.

This is the place to post your question about the new forums and ask for help or additional features.

Moderators: Betsy M, dknapp1

Re: How to embed a youtube video in your post.

Postby Site Administrator on Fri Sep 24, 2010 3:49 pm

Here's a shortcut to get the right version of the URL - click on the "Share" button below the video and copy the URl that pops up:
Screen shot 2010-09-24 at 3.45.44 PM.png

If you don't see that the "Share" button, it means that the person who uploaded the video has disabled embedding.
User avatar
Site Administrator
Site Admin
 
Posts: 166
Joined: Thu Jul 24, 2008 9:43 am

How to embed a youtube video in your post.

Postby Boon on Fri Sep 24, 2010 11:26 am

How to embed a youtube video on the VWA Forum:

For starters, know that you DO NOT use the "embed" code provided by youtube to make it work - it won't. The technical reasons are beyond me, but it has something to do with compromising site security so just take my word for it. But in fact, the way it's done on the VWA Forum is actually a little less complicated. So here goes:

1) Find the video you want to share from http://www.youtube.com, and then from your browser's address bar up at the top of the screen select and copy the URL of that particular video. It'll look something like this:

http://www.youtube.com/watch?v=SbWg-mozGsU

This is done by holding down the left mouse button while dragging your cursor over the URL to highlight it, then right clicking the mouse and choosing "copy."

2) In a new browser window or tab, open up the VWA forum and log in. Then click either the "New Topic" button or "Post Reply" button (if it's an existing thread you want to contribute to), and up will come the posting input screen. Of course you can write any text you like, but when it comes time to embed the youtube video, you...

3) Click on the "youtube" button at the far right of the line of formatting buttons immediately above the input box. This will insert the following tags into the body of your text input:

[youtube][/youtube]

4) Place your cursor right in between these two tags, right click, and select "paste" to insert the youtube URL that you previously copied. In most cases this takes care of it, BUT...

5) Some youtube URLs have some extra "stuff" appended to the end of the URL that confuses the forum program that parses them, and they won't work. Rather than embedding the video, it just displays the URL and tags. Here's an example of a workable youtube URL on top, and a cluttered unfunctional one below it - both referring to the same video:

-http://www.youtube.com/watch?v=SbWg-mozGsU
-http://www.youtube.com/watch?v=SbWg-mozGsU&feature=related

What you need to do if your URL is cluttered or your video doesn't embed when you preview it is simply remove the ampersand (&) and everything to right of it from the URL, but not the closing youtube tag. It should look like this in the forum input screen when it's ready to post:

[youtuube]http://www.youtube.com/watch?v=SbWg-mozGsU[/youtuube]

Note that there's no "&" or anything to the right of it in the URL. (I've added an extra "u" in the tags so that this example won't be executed by the program, displaying an embeded video rather than the text. Of course you will use the tags as provided when you click the "youtube" button.)

When you think you have it right, click the "preview" button below the input box. If your video shows up as a youtube image in the preview, you're ready to post it so scroll down and click "submit." If it just shows up as a line of text with tags, make sure that ampersand (&) and everything to the right of it has been deleted from the URL, and preview it again. With any luck it'll work this time.

What'll they think of next?

User avatar
Boon
 
Posts: 137
Joined: Wed Jul 30, 2008 8:38 am
Location: California Coast Range


Return to Forum Help

Who is online

Users browsing this forum: No registered users and 1 guest